Menus

The menus in SiteSucker contain commands and options that allow you to control the application. Many of these features can also be accessed using the toolbar. SiteSucker provides the following menus:

SiteSucker

SiteSuckerMenu

The SiteSucker menu (or application menu) has commands for performing common tasks such as setting application preferences and quitting. The SiteSucker menu provides the following menu items:

File

FileMenu

The File menu allows you to create, open, close, and save SiteSucker documents, as well as perform other file-related tasks. This menu provides the following menu items:

Edit

EditMenu

The Edit menu includes standard and custom editing commands. It provides the following menu items:

View

ViewMenu

The View menu includes standard and custom commands for modifying the appearance of SiteSucker's windows. It provides the following menu items:

Control

ControlMenu

The Control menu allows you to control the download. It provides the following menu items:

Settings

SettingsMenu

The Settings menu lists all your saved settings files. (The Preferences window lets you save settings files.) Select a file's name in the menu to assign its settings to the active document. All settings in the menu that match the settings of the active document are shown with a check mark. The Settings menu provides the following menu items:

History

HistoryMenu

The History menu displays the forty most recently used URLs. When you choose a URL from the menu, SiteSucker enters it into the URL text field.

You can use the ⌘-Option-Arrow keys to cycle through the list of recently used URLs.

Choose Clear Menu to delete all URLs from the menu.

Bookmarks

BookmarksMenu

The Bookmarks menu displays bookmarks read from a web browser. When you choose a bookmark from the menu, SiteSucker enters its associated URL into the URL text field.

The Preferences window lets you specify the source of the bookmarks. If No Bookmarks is specified in the preferences, the Bookmarks menu is not shown.

Window

WindowMenu

The Window menu includes standard window commands. It also lists all SiteSucker windows that are open. Select a window's name in the menu to bring it to the front.