Menus

The menus in SiteSucker contain commands and options that allow you to control the application. Many of these features can also be accessed using the toolbar. SiteSucker provides the following menus:

SiteSucker

SiteSuckerMenu

The SiteSucker menu (or application menu) has commands for performing common tasks such as setting application preferences and quitting. The SiteSucker menu provides the following menu items:

File

FileMenu

The File menu allows you to create, open, close, and save SiteSucker documents, open the destination folder, and perform other file-related tasks. This menu provides the following menu items:

Edit

EditMenu

The Edit menu provides standard and custom editing commands. It has the following menu items:

View

ViewMenu

The View menu lets you display the SiteSucker queue, customize the toolbar, and navigate the Settings dialog. It provides the following menu items:

Control

ControlMenu

The Control menu allows you to control the download. It provides the following menu items:

Settings

SettingsMenu

The Settings menu lists all your saved settings files. (The Preferences window lets you save settings files.) Select a file's name in the menu to assign its settings to the active document. All settings in the menu that match the settings of the active document are shown with a check mark. The Settings menu provides the following menu items:

History

HistoryMenu

The History menu displays the ten most recently used URLs. When you choose a URL from the menu, SiteSucker enters it into the URL text field.

You can also use the Command-Option-Arrow keys to cycle through the list of recently used URLs.

To delete all recent URLs, select Clear Menu.

Bookmarks

BookmarksMenu

The Bookmarks menu displays bookmarks read from a web browser. When you choose a bookmark from the menu, SiteSucker enters it into the URL text field.

The Preferences window lets you specify from which browser the bookmarks are read. If No Bookmarks is specified in the preferences, the Bookmarks menu is not shown.

Downloads

DownloadsMenu

The Downloads menu gives you easy access to your downloaded files. Whenever you start a download, the first file downloaded is added to this menu. The menu is organized by host name, and only files in the destination folder for the active document are shown.

Choose an item in the menu to open it. If you choose the Edit item, the Downloads Editor is displayed, which allows you to remove, rename, or reorder items in the menu.

Window

WindowMenu

The Window menu lists all SiteSucker windows that are open. Select a window's name in the menu to bring it to the front. The Window menu also provides the following menu items: